0

Recently I have been getting fed up with Google Analytics, as it is missing a lot of information, whether it not being there to begin with, or getting anonymous data (such as browser used).

I have AWStats on my personal website, which is hosted through a different company to the one where I work use, and it isn't installed natively. So I tried to install AWStats, however, I have no idea what I'm doing, and the documentation isn't very clear: http://www.awstats.org/docs/awstats_setup.html

I extracted the AWStats zip file, and put in onto my server, via ftp, in a folder called "awstats". I then logged into the server through PuTTY, through the root, and ran the command

perl awstats_configure.pl

As is stated on the site linked, and it says

Can't open perl script "awstats_configure.pl": No such file or directory

So I tried doing:

perl awstats/awstats_configure.pl

But that still didn't work.

Any idea where I am going wrong? As ugly as AWStats interface is, from my experience it is a lot more reliable that Google Analytics, although I wouldn't remove that (the more data the better), so I would like to get it working.

  • 1
    Yeah. You are not using Piwik. ;-) No kidding. Piwik is the best out there and it is free. AWStats has never really told me anything. I used to be a webhost and installed AWStats for all of my customers. However, no-one used it. Really. No one! I also offered automated "canned" and custom reports from Sawmill just for that reason and that was far more useful. I like Piwik more than Sawmill which is really really expensive. Too bad I already shelled out the money. – closetnoc Oct 5 '15 at 14:28
  • Alright. Did you cd into the directory where the install/configuration file is?? Sometimes hinky stuff happens and it always best when you can to go to the directory before trying to execute. – closetnoc Oct 5 '15 at 14:31
  • No, how would I do that? (I have never really done CLI before), the way to said file is: root/awstats/wwwroot/cgi-bin/ – Jordan Oct 5 '15 at 14:37
  • You would cd root/awstats/wwwroot/cgi-bin/ – closetnoc Oct 5 '15 at 14:41
  • Thanks :) Now, I don't know WHAT I have done, but it's working :) – Jordan Oct 5 '15 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.