4

I installed phpmyadmin over a year ago.

I use MAC OS 10.10.4. I don't use Xampp. My installation Folder is /Library/Webserver/Documents/phpmyadmin.

Now when I try to access phpmyadmin with that url, http://localhost/phpmyadmin/, i have:

403 Forbiden error You don't have permission to access /phpmyadmin/ on this server.

in /var/log/apache2:

[Sat Oct 03 15:42:53.773654 2015] [autoindex:error] [pid 10682] [client 127.0.0.1:57694] AH01276: Cannot serve directory /Library/WebServer/Documents/phpmyadmin/: No matching DirectoryIndex (index.html) found, and server-generated directory index forbidden by Options directive

My question is how can i fix it and have an access to phpmyadmin again?

Ok, the answer of Rishi has solved the acces denied problem.

For the rest of the problem (index.php was downloaded but not executed), i had to (on httpd.conf): Uncomment LoadModule php5_module libexec/apache2/libphp5.so and add: AddType application/x-httpd-php .php AddType application/x-httpd-php-source .phps AddType text/html .php (maybe the only one really necessary??)

see https://stackoverflow.com/questions/18422140/apache-is-downloading-php-files-instead-of-displaying-them

1

Depending on your setup, you need to locate the correct .conf file (like apache-xampp.conf or httpd.conf or apache.conf or phpmyadmin.conf) in your web server installation directory for below lines and then Ctrl+F for phpmyadmin to find something like below:

<Directory /usr/share/phpmyadmin> ## The path here will vary depending on your setup and you don't have to change it
    Options FollowSymLinks
    DirectoryIndex index.php
    order deny,allow
    #deny from all
    allow from all

and change it to

<Directory /usr/share/phpmyadmin>
    Options Indexes FollowSymLinks MultiViews
    DirectoryIndex index.php
    AllowOverride all
    Require all granted

If you are going to access phpmyadmin from localhost only then you may use Allow from 127.0.0.1 instead of Require all granted above.

Restart apache service once you are done.

  • Thanks a lot for your answer. I have modified my /etc/apache2/httpd.conf as you said (but the path /usr/share/phpmyadmin is not specified). Now i can access the file but the code is not interpreted. Do you have an idea for that? – Sebastien Cavaignac Oct 3 '15 at 20:45
  • the path /usr/share/phpmyadmin in your case will be the path of your phpmyadmin directory – 000 Oct 4 '15 at 4:35
  • Ok so for me the path is /Library/WebServer/Documents. So i can access to the index.php file but it is not interpreted. What can i do ti fix it please? – Sebastien Cavaignac Oct 6 '15 at 20:24
  • Please update your post with details about version of xampp or lamp that you are using and OS details and the directory where you have installed and with what user permissions.. – 000 Oct 7 '15 at 16:58
  • I have edited my post with those information even if now everything is ok with my phpmyadmin installation. – Sebastien Cavaignac Oct 8 '15 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.