3

My goal: Buy domain on Godaddy, point it to Cloudflare nameservers, utilize Cloudflare functionality, and serve the content from my existing hosting provider.

The Problem: Adding the domain in my hosting cPanel - Addon Domain module in the cPanel rejects the domain with the following error:

Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.

Here's my domain's GoDaddy DNS configuration: enter image description here

Here's my Cloudflare configuration: enter image description here

Here's online DIG result:

 ; <<>> DiG 9 <<>> @localhost example.com A
 ; (1 server found)
 ;; global options: +cmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62386
 ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

 ;; QUESTION SECTION:
 ;example.com.  IN  A

 ;; ANSWER SECTION:
 example.com. 300   IN  A   104.28.26.98
 example.com. 300   IN  A   104.28.27.98

 ;; Query time: 19 msec
 ;; SERVER: 127.0.0.1#53(127.0.0.1)
 ;; WHEN: Mon Sep 14 22:00:03 2015
 ;; MSG SIZE  rcvd: 75

I've tried asking CF support, but they haven't replied in 8 hours.

  • 1
    You'll need to change the nameservers back to GoDaddy's default nameservers temporarily (assuming you're using a GoDaddy cPanel hosting account as well). Then add the domain in cPannel. I'd suggest then deleting the site in CloudFlare, if you tried to add it there, and just add the site back so that CloudFlare will re-scan the DNS. I'd suggest waiting about 15 minutes before doing this last step so that GoDaddy has enough time to update its DNS tables. Finally add the CloudFlare nameservers for the site back into GoDaddy's DNS Settings (as you have in the image above). Good luck. – dan Sep 15 '15 at 5:25
3

Sorry, the domain is already pointed to an IP address that does not appear to >use DNS servers associated with this server. Please transfer the domain to this >servers nameservers or have your administrator add one of its nameservers to >/etc/ips.remotedns and make the proper A entries on that remote nameserver.

This means that GoDaddy have cPanel set up to only allow domains pointing to their nameservers to be allowed as addon domains.

As a workaround, you can set your domain to GoDaddy's nameservers, add the addon domain after a few minutes (Let DNS propagation take place!) and then change the nameservers back to CloudFlare.

Once the domain is in cPanel, it does not continue to check that it is set to the correct nameservers and so this should sort your issue.

Credit to Dan also for this workaround.

  • @Housemd Seems this is repeating my earlier comment above...but that's OK, and answer is an answer (though a nod is always appreciated for the effort). – dan Sep 16 '15 at 0:47
  • @dan Sorry dude, I completely overlooked your comment. I am thankful for the nod. – Housemd Sep 16 '15 at 1:51
  • 1
    @Housemd No worries. Keep in mind that each time you need to make a DNS change for cPanel, or other DNS changes such as updating the contacts...you'll need to switch back to GoDaddy's nameservers, and then afterwards you can change them back to CloudFlare's (that's an inherent limitation when using this combination). – dan Sep 16 '15 at 2:52
  • Sorry Dan, didn't see your comment. I'll add some credit. – Peter Bishop Sep 16 '15 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.