3

All the hosted websites on my VPS stopped working yesterday. I have not changed any settings since a week. The websites result in an ERR_CONNECTION_REFUSED.

In my time zone, the websites stopped working at 2015-9-10 somewhere between 15:00 and 16:30.

Though the plesk panel is still working. There is no error message in that panel when I log in. I already tried to restart the server twice. Also tried to restart apache webserver and nginx, did all not help.

License

This might be interesting: The next license key update is on 2015-09-23. Also, I tried to submit a support request at the Odin website. Entering my license for that request result in the message 'Entered license key is either not valid or not eligible for email support'. Although the license was bought at a certain date. Could that cause the problem?

Should I buy a new license? If the license is the cause, why would there be no message to tell that?

Update

The night before the hosted websites stopped working (from 2015-9-9 to 2015-9-10), plesk was updated from #63 to #64:

127.0.0.1 admin [2015-09-10 02:16:06] 'Update Domain Status' ('Client GUID': '(..)' => '(..)', 'Domain GUID': '(..)' => '(..)', 'Domain Name': '(domain-name-1)' => '(domain-name-1)', 'Extended status of domain': 'active' => 'suspended', 'Status': '0' => '4')
127.0.0.1 admin [2015-09-10 02:17:43] 'Update Domain DNS Zone' ('Client GUID': '(..)' => '(..)', 'Domain GUID': '(..)' => '(..)', 'Domain Name': '(domain-name-1)' => '(domain-name-1)')
127.0.0.1 admin [2015-09-10 02:17:43] 'Update Domain Status' ('Client GUID': '(..)' => '(..)', 'Domain GUID': '(..)' => '(..)', 'Domain Name': '(domain-name-1)' => '(domain-name-1)', 'Extended status of domain': 'suspended' => 'active', 'Status': '4' => '0')
127.0.0.1 admin [2015-09-10 02:17:47] 'Change status of additional domain' ('Client GUID': '(..)' => '(..)', 'Domain GUID': '(..)' => '(..)', 'Domain Name': '(domain-name-1)' => '(domain-name-1', 'Extended status of domain': 'active' => 'suspended', 'Status': '0' => '4')
   ( - and so on for all other domains -)
[2015-09-10 04:37:09] 'New patch installed' ('Update version': '63' => '64')

Released from monitoring

I also received a e-mail:

The Web Proxy Server (Nginx) service on host ( - hostname -) has been released from monitoring on Sep 10, 2015 05:57 PM.

Extra information

  • CentOS 6.6 (Final)
  • Plesk version: 12.0.8 Update 64, last update was one hour ago. But that did not solve the problem.

So, how can I make the websites make work again?

  • Try running /etc/init.d/httpd status. What output is provided? Also, check your firewall to make sure port 80 is open. – Peter Bishop Sep 11 '15 at 13:22
  • I rather suspect that you really need to deal with your provider on this one. I would call them and ask them Whiskey tango foxtrot?? It would be a much faster solution. If that does not work, try calling other departments such as sales/marketing and see if they can get you some help- after all- they do not want to lose a customer!! Be kind and explain the trouble you are having getting help first and then the problem. See if they can short-circuit the process and get you a tech-rep ASAP. – closetnoc Sep 11 '15 at 14:44
5

I had the exact same problem (well symptoms at least)...

To fix the issue, I executed the following commands:

/usr/local/psa/admin/sbin/nginxmng --disable
/usr/local/psa/admin/sbin/httpdmng --reconfigure-all

Hope this helps. :)

| improve this answer | |
  • I know your not supposed leave comments of thank you, but THANK YOU. This truly saved my bacon! I came on one morning to find that 2 dedicated servers we own running plesk 12.0.18 were not allowing users to access websites we hosted. But the servers were online. Thanks again! – pleshy Nov 25 '16 at 10:03
  • This is still an issue on Plesk Onyx Version 17.0.17 on CentOS Linux 7.3.1611 @frijj2k's answer is still relevant and useful. – ctrl-alt-dileep Feb 27 '17 at 9:22
-2
/usr/local/psa/admin/sbin/nginxmng --disable
/usr/local/psa/admin/sbin/nginxmng --enable 

did it for me

| improve this answer | |
  • Can you explain what these commands are supposed to do or provide links to the documentation? – Stephen Ostermiller Oct 26 '15 at 19:19
  • The part that actually resolves this is just the enable, this disable is not required. – Laice Jan 14 '16 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.