2

I hope some one can point me in the right direction here, I am trying to move a Cpanel account from a dedicated server to a small VPS however when I try to restore the account on the destination VPS I get the following error :

No such file or directory at /usr/local/cpanel/Whostmgr/Transfers/Utils.pm line 222. ”

I have tried creating new backup and uploading again but get the same problem every time.

There is a thread at Cpanel's official forum but it ends abruptly without any resolution : https://forums.cpanel.net/threads/cant-restore-account-from-cpmove-backup.474061/

Could some one tell me what is causing this and how I can resolve this.

I have more then enough space at both the source and destination VPS.

1

Firstly, try to open the cpmove file on your own PC. Does it open? Do you get any errors? This is to check for corruption.

Assuming you have WHM access on both servers, you could use the Transfer Tool under Transfers instead. This is the recommended way to perform transfers.

Finally, you should really read through this documentation as it provides you with all the necessary instructions on how to properly restore a cpmove file.

  • I extracted the backup file and it looks good to me, no errors. I had already moved 6 accounts without a problem. The only thing I had done before I started getting this problem is I disabled DNS and I disabled Horde. I see something about Horde in the link you have provided so I am going to try enabling Horde and do that again. I assume DNS does not make any difference but I will try enabling that as well if enabling horde alone does not work. – Parminder Singh Chahal Sep 3 '15 at 20:20
  • 1
    I'm not entirely sure however, DNS may make a difference if it was present on the account on the server you are migrating from. DNS entries are also held in the cpmove file. For that reason, may I suggest also enabling DNS until all transfers are complete, then deactivate. That way, the transfer tool should have no reason to complain. The Horde information is simply regarding backwards compatibility. As long as both servers are the same version (Preferably the latest in the upgrade tier you have selected), there shouldn't be an issue. – Peter Bishop Sep 4 '15 at 8:52
  • 1
    The important thing to note from the docs is The restore system uses multiple applications, such as MySQL®. Do not shut down or restart any processes on the server during the restore process.. This makes me believe further that all services should be activated for the install, including DNS. – Peter Bishop Sep 4 '15 at 8:55
  • 1
    I have found out that my VPS is short of inodes. Host increased that for me and I am done restoring accounts. – Parminder Singh Chahal Sep 4 '15 at 20:53
  • 1
    This move was from a dedicated server with 64GB RAM to a VPS with 2GB RAM :) I guess it would take some time for me to learn to use resources efficiently. Thanks for your help every one. I dont know how to close this so I am accepting the only answer as best answer as these comments could be read by whoever comes looking for a solution to similar problem. – Parminder Singh Chahal Sep 4 '15 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.