2

I have two websites. One is hosted on /var/www (www.example.com) and the other is /var/www/test (test.example.com). The second is a VirtualHost.

I wrote a .htaccess (I'm using it to mod_rewrite), put it into /var/www/test, and enabled AllowOverride all on the /var/www <Directory>.

Yet, when I go to the webpage www.example.com/test, Apache processes it, while if I go to test.example.com it doesn't.

What can I do to fix the problem?

  • Do you have Options +FollowSymLinks on your test.example.com VirtualHost? What version of Apache are you running? – MrWhite Aug 27 '15 at 21:06
1

Add AllowOverride All in the directory settings within the vhost and that should solve your issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.