0

The disclaimer: I've looked around for this for a while and didn't find anything - I'm guessing it's a common question and I just don't know how to ask it so sorry about this (almost certainly) being a duplicate.

OK, here's the problem: So I have a shared server (through Arvixe) and I recently updated my site (by renaming some of the files) via ssh: foo.htm -> foo2.htm, index.htm -> index2.htm, etc. When I go to my site the old file is still there (I can type www.myaddress.com/foo.htm and it works) but the new file is not (www.myaddress.com/foo2.htm doesn't exist). Cache could explain the old file loading, but the lack of the new file is baffling (also cleared my cache and tried it on a new computer for sanity checking). This tells me that my server is not working how I think it's working (i.e. making a change on the server makes a change on the site). So the question is, why are my changes not reflected to my site?

A brief addendum: This also happened with a wordpress install. I installed using softalicious and when I deleted the wp/ directory in my public_html dir the site still showed up. I figured that this had something to do with the installer doing some behind the scenes thing (though I wasn't totally convinced). I had to uninstall via softalicious to get it to go away.

My Guess: Is this just my server is being reflected to another server for actual site loading? My server's IP is different than when I ping my site.

  • 2
    Sounds like your server is using a proxy cache, like vanish or Cloudflare CDN. Have you spoken to the web hosting company? Your hosting company should always be first point of call ;) Because they know their setup, we don't. – Simon Hayter Aug 20 '15 at 15:02
  • I've submitted a ticket. Phone and online help are busy, been checking for hours. Sounds like what's happening though. – Ben Kushigian Aug 20 '15 at 15:36
  • Theres a chance someone may have access to your system and is deleting your files. And by someone, it may even be a robot as well. – Mike -- No longer here Aug 20 '15 at 17:27
  • @mike and that's highly unlikely what's happening here and quiet an assumption to make based on the information provided. – Simon Hayter Aug 20 '15 at 21:18
  • Yeah, all my stuff was in place - just not according to my we browser. I just went with a different hosting company. It was definitely a proxy cache as Simone said. – Ben Kushigian Aug 21 '15 at 4:02
1

While I certainly wouldn't consider it best practice, nor appropriate to do this without informing the customer, it is possible that your hosting provider, if they also manage your domain name and DNS settings, could have moved your website to different server either temporarily or permanently in order to keep your website online while carrying out maintenance work on the original server or decommissioning the original server (perhaps it was old, slow, had hardware issues etc?).

If this is the case, then the server you are uploading files to (perhaps via FTP or SFTP etc) is no longer the server responsible for hosting your website.

One way you can check this is to see if the IP address you are uploading to, matches the IP address behind your website. For example, from a command prompt you might type:

ping ftp.myaddress.com
ping www.myaddress.com

where ftp.myaddress.com is replaced with whatever server hostname you are uploading files to, can be found in your FTP software settings, and www.myaddress.com is replaced your website address. If both of these reveal the same IP address then you can ignore this answer. Whilst I really don't like this scenario it has caught me out previously with at least one hosting provider.

| improve this answer | |
0

Next time when this happens, you can circumvent the proxy cache and see what's on your server directly. Instead of using your domain name and going to wwww.myaddress.com/foo2.htm you can direct your browser to your server explicitly, avoiding the dns lookup and any magical stuff inbetween: http://<your server's ip>/foo2.htm

| improve this answer | |
  • I tried this and it went to a misdirect. – Ben Kushigian Aug 21 '15 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.