1

I am getting this warning of disk quota on my website. I have searched a lot. Every where they say its due to the insufficient space. I checked through cpanel, the total space allotted is showing 40 GB, while the used space is 1.99 GB.

I even checked by removing the contents of tmp directory, but this warning is still showing.

Can any one help?

  • 2
    Did you contact your server provider about this? there should is something wrong there. If you remove content then does it changing size of disk space? – Helping Hands Aug 4 '15 at 5:38
  • Is the user of the php process different from that of the /tmp folder? Perhaps the permissions are incorrectly setup – Mike Aug 4 '15 at 5:44
  • Do you have a lot of files? You could also be hitting your 'inode' limit. Following up with your hosting provider seems like the best option here. – Nick Aug 4 '15 at 7:04
  • @HelpingHands Yeah, the contact has been made. They are saying that, the some of the process of website have either not been closed off correctly or continue to run for some reason. Also, when i removed contents from tmp directory or any file from the root directory then the warning does not show for few minutes after that it reappeared – Kumari Manisha Aug 4 '15 at 7:49
  • @KumariManisha - Then there is something like cron job or spamming is there to your website which continue running in background and put loading to your site. – Helping Hands Aug 4 '15 at 8:11
1

One possibility could by e-mail inbox size. Often this is included in the size count.

Check your mailbox via webmail (not your mail software) to check the actual contents of your mailbox. If this is the case, check the settings of your mail software. Often there's an option like "leave a copy on the server" (which is fine) accompanied by a "remove from server after X days".

The latter might not be checked or set. If not, set it. Something like 10 days should do, but 30 days is an option too (but, requiring more space since you can gather mails for a month).

If you delete files, you create room for new mails. The error is gone for a few minutes while new mails which where in the queue drop in, and your mailbox/disk is full again. This is a background process.

  • Good thought. In addition, there is a "null route" style folder where [spam] mails for non existent addresses may be getting sent...although it may not be available on all shared servers, or may not exist if you have a catchall email for non-existent addresses. In CentOS variants it is found above public_html in /home/myaccount/mail/new – dhaupin Aug 4 '15 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.