2

I visited Google Webmaster Tools(Google Search Console) today after resubmitting sitemaps for my website, and while Google is happy to index more HTML pages of my site, it however has not indexed a single image yet.

So I then used the "Fetch as google" tool and attempted to load a URL in its interface, and their interface reports an error, but it doesn't state what the error is or why. There is no error at my end, and according to the logs on the server itself, there is also no error. This is my last log entry coming from google to prove the server has no problems:

66.249.75.241  [26/Jul/2015:00:24:35 -0400]  GET /fs6137-0-0-0-u0 HTTP/1.1 200  63211  -  Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)

fs6137-0-0-0-u0 is the image file and I named it as such to try to prevent people from easily accessing the normal images without visiting the website first. Status 200 of course means content, and the size is 63K.

So here's my question. How long will it take before Google begins to produce valid results on every page fetch?

  • 2
    I don't think the "Fetch as Google" tool is intended to be used on images? I get the same generic "Error" if I attempt to directly request a publicly available image. But then it's not the standard "Googlebot" that is responsible for indexing images, it's the "Googlebot-Image"-bot. – MrWhite Jul 26 '15 at 14:14
  • I rather suspect that the lack of a file extension is keeping your images from being indexed for image search. To test this theory, I did a site: search for my domain and then clicked images and the one and only image without a file name extension is not in the list. It is not a conclusive test of course, but may be enough of a hint to try and experiment to prove this theory out. – closetnoc Jul 26 '15 at 14:42
  • 1
    @closetnoc The file extension really should not have anything to do with indexing. The internet does not work on file extensions; it works on mime-types. There are images indexed that do not have a file extension. (Difficult to find admittedly, because most people use file extensions; but they are there.) – MrWhite Jul 26 '15 at 14:56
  • @w3d I don't disagree. It was just a suggestion to test to see. Google can do what they want regardless of what we feel is right or wrong... ;-) ...we have seen it before. It could also simply be an omission in code- possibly for historic reasons- who knows. There may be specific conditions where an image without a file extension would or would not be indexed that can be discovered. There could be a quirk somewhere in code. I am willing to bet a beer (not a heavy better) on this (and be careful- I do not place bets easily, most of the time I already know the outcome). – closetnoc Jul 26 '15 at 16:06
  • 1
    @w3d This is not an argument, I was just beginning a search and this is the first thing I found: support.google.com/merchants/answer/160640?hl=en where it is said: Make sure that your images are in one of our supported formats (GIF, JPG, JPEG, PNG, BMP or TIF) and their filenames include the appropriate extensions. It also states that it can take 6 weeks for images to show up- I don't completely believe that of course. As well, the images may be indexed, however, it appears that under certain circumstances the results can be different based upon the client browser, network, etc. – closetnoc Jul 26 '15 at 16:21
1
  • Method 1: Check your robots.txt and sitemap.xml file. Maybe you disallowed Google to crawl the folder or file.
  • Method 2: Try to rename your image.

It can take some hours or days.

Find more infos under https://support.google.com/webmasters/answer/182072.

  • 3
    Can you successfully request an image-URL using the "Fetch as Google" tool? – MrWhite Jul 26 '15 at 14:15
  • It must work: support.google.com/webmasters/answer/6066468 – Suriyaa Jul 26 '15 at 14:16
  • 2
    Well, you might think, but have you tried? The tool is really designed for fetching pages and it's associated resources (when doing a "Fetch and Render") - not images directly. If I try to request an image directly (one that is publicly available and not blocked by robots.txt etc) I get the same generic "Error" as the OP. Personally I think this is by design - although the "Error" could be a lot more helpful. – MrWhite Jul 26 '15 at 14:22
  • Last month I got the same error and I checked my html, css and js files. Correct your image links in these files. Now it works! – Suriyaa Jul 26 '15 at 14:32
  • 2
    Although the error in the question is the result of requesting an image URL directly using the tool - this has nothing to do with HTML, CSS and JS files. Have you tried passing a URL of the form /path/to/image.jpg (ie. an image) to the "Fetch as Google" tool? – MrWhite Jul 26 '15 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.