Some time back we found this very old, and no longer supported, plugin which helped us define our URL exactly the way we wanted it - see more on the issue from this previous post. Our Knowledge Base is hosted on WordPress, but our site is not, so the KB theme kept wanting to add in extra slugs to the URL. Unfortunately it was the only one we could find that actually did the job.

The plugin worked great... until we wanted to add a new article. I get this error message:

Remove Slug Custom post type error! .htaccess is not writable, please add following lines to complete your installation:

RewriteRule ^forumsforum/(.+)$ /$1 [R=301,L]

RewriteRule ^forumstopic/(.+)$ /$1 [R=301,L]

RewriteRule ^forumsreply/(.+)$ /$1 [R=301,L]

RewriteRule ^articles/(.+)$ /$1 [R=301,L]

If I ignore it and publish the article, the slug is actually correct, but if you visit the post it throws a 404 error.

How do I update the plugin so that I can continue adding new articles? I am not sure how/where to use the information in the error message.

  • That has nothing to do with the plugin (other than the fact it is trying to write to a file on your site). The clue was .htaccess is not writable and @Eike's answer below will resolve this problem.
    – zigojacko
    Jul 21, 2015 at 9:56

1 Answer 1


.htaccess contains the rules that tell your server how to resolve the human readable urls so that they display the correct entry (internally wordpress still uses urls with query parameters, the rewrite mechanism hides them from a users view).

Your Plugin want's to add new rules to the htaccess file, however it lacks necessary write permissions on the file and can't do so automatically. So it asks you to add the rules. Without the rules the Urls cannot be resolved properly and thus they fail and result in a 404 error.

Start your FTP programm, check that it has an "show hidden file" option and that this is enabled (files that start with a dot, as .htaccess does, are not usually visible in Unix file systems via ftp), open the htaccess file and add the lines and then re-upload to the server). If this does not work you need to see if you can change file permissions (note the original permissions, change everything to 777, add rules to file and change back to the original permissions). If you can't change file permissions you need to contact your server administrator.

If this is the only problem with your plugin this should do the trick.

  • Thanks for your suggestion. I tried updating the htaccess file with the entries mentioned in the error and it works on the first article you add but the next article you try add pops up with the same error, this is because the htaccess file is reverting back to its original state again. I then changed the permissions of the htaccess file as per the solution suggestion and re added the entries it required but was again able to add only one article before the error popped up. I checked the htaccess file again and the permissions and entries I had added had yet again reverted back.
    – walbuc
    Jul 21, 2015 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.