1

Last month we removed parent category path from the sub category URL's. After that we changed the sitemap file with new URL's and submit it to the webmaster tools for indexing.

For example example.com/display-cabinets/display-counters has been changed to example.com/display-counters

The problem is still the new URL's are not getting indexed by Google. I have done everything like removing breadcrumbs and used "Fetch as Google" option for re-crawling, but nothing worked.

Can anyone please tell me a solution for this issue?

1

Search engines are notoriously slow. The reason for this is simple. The internet is so vast that it is impossible for any search engine to highly responsive.

I am sure some of your pages will show-up correctly while others will take longer. Just make sure you did all your work correctly and either 404 the old URL or 301 redirect them to the new path. Your choice.

I would 301 the old pages to the new pages if possible for a period to make sure all the new URLs show up correctly, then remove the 301 redirect and let the old pages 404 for a period. Then you will be done. Otherwise it is okay to let the old pages 404 and wait for the search engines discover the new pages as they will.

Just know that using a 301 redirect will preserve any link value to that page for as long as the 301 redirect exists. It is possible to create the 301 redirect using a single .htaccess rule and leave it for as long as you like.

  • Are you looking at Google.com or Google.co.uk? There will be a difference though I cannot tell you exactly what that difference is. Again, it can take more than just a couple of weeks. I can take months for Google to catch-up. So when yo say last month, I do not know if that is 2 weeks or 30 days ago. I would be concerned if it is 30 days, but not concerned if it is only 2-3 weeks. – closetnoc Jul 12 '15 at 22:37
1

What you can try is to go to Google Webmaster Tools, then select the website then the gear icon then site settings and select that you'll define the crawl rate (instead of letting google choose it). Next, use the slider to change the crawl rate to the maximum. Depending on how popular your site is, the maximum could range from google making 2 to over 10 requests per second.

Then wait at least a week and if you don't get results, then check the search analytics section to see what people search for and where your website ranks (under the position column). Any position of over 20ish means your page probably doesn't appear in the first page of search results.

  • 1
    Thanks mike. I followed your advice and it worked. The pages got indexed. – Avenger Jul 13 '15 at 16:13
  • Crawl rate refers to the speed of Googlebot's requests during the crawl process. It doesn't have any effect on how often we crawl or how deeply we crawl your URL structure. If you want Google to crawl new or updated content on your site, use Fetch as Google instead. support.google.com/webmasters/answer/48620?hl=en – user29671 Jul 14 '15 at 7:30
  • Please read the question again. I already mentioned "I have done everything like removing breadcrumbs and used "Fetch as Google" option for re-crawling, but nothing worked." Now I hope you understand that I already used Fetch as Google. Changing the crawl rate worked for me. – Avenger Jul 15 '15 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.