5

I had a problem logging in my ftp account with old login-password (I don't know why, I have changed it to try again, but there is no positive result). So, I made a new FTP account in my CPanel - and I successfully logged in in my Firezilla, but there is only file .ftpquota and no other files. My website is working, but I can't change files in FTP. How to solve it?

4

When you create a FTP user account in cPanel you assign it a ownership directory, if that folder happens to be a child directory of the master account then you won't be able to go higher. e.g

  • /home/your-username/public_html/new-user/ Will not be able to view the parent public_html.

This is a security messure and something you shouldn't need to turn off. Your issue is the old FTP account that you should try and resolve. You should be able to reset it via CPANEL or contact your hosting. Simply creating another user will not give you the access rights you need unless you have a good understanding of how chmod works.

Your options

  • Reset the main password to the FTP account.
  • Change the new FTP user to the root of where the HTML files are stored, while granting correct chmod premissions.
  • Contact your Web Host... after-all, that's what they are their for....
  • 1
    Thank yo so much for such a detailed answer! The problem is solved, your answer helped a lot! – user3748765 Jun 28 '15 at 16:20
0

While adding new FTP account, you need to put "public_html" folder in 'Directory' input field. So create new FTP account with Directory listing set to public_html, and the trying logging through FTP client. Worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.