I need to install Java and ANT on my 1and1 hosted web server but can't get it to work. I'm very unfamiliar with Linux terminal commands.

I've tried sudo and su commands but apparently they don't exists and commands like "sudo apt-get update" return that sudo does not exists.

I believe my host is Debian so I've tried this:

aptitude install sudo

but I got the following:

E: Opening /etc/apt/sources.list - ifstream::ifstream (13: Permission denied)E: Opening /etc/apt/sources.list - ifstream::ifstream (13: Permission denied)E: The list of sources could not be read.

So how can I install sudo and/or install Java and ANT?

  • 1
    Which service exactly did you subscribe to? Is it a managed server? A root server? Or just web hosting?
    – Daniel B
    Jun 4, 2015 at 14:17
  • "1and1 business linux"
    – idn
    Jun 4, 2015 at 15:34
  • 1
    how can I install sudo simple you don't, if you want to install stuff you need to have a VPS, CLOUD VM, or a DEDICATED SERVER. Jun 5, 2015 at 7:31
  • You need to purchase VPS or dedicated server. If you use shared hosting, you cant install it
    – Mark Shawn
    Jun 9, 2015 at 5:35

2 Answers 2


You have a shared hosting plan. That means you cannot install software. Your SSH access is primarily meant for managing files remotely.

You may be able to run Java or whatnot with your account, but not as a server/service.

Generally, the minimum required hosting package for installing your own software is a virtual server (also called virtual machine, cloud server, ...). They’re quite cheap, too, these days. However, you need to keep it secure and up-to-date yourself. If you’re “very unfamiliar with Linux terminal commands”, this is not an option for you.

  • Thanks. you said "ou may be able to run Java or whatnot with your account, but not as a server/service." How can I do this?
    – idn
    Jun 4, 2015 at 19:45
  • Java is available from Oracle as a simple archive. It can be unpacked and run from any directory. That's, of course, provided the capability to execute hasn't been disabled.
    – Daniel B
    Jun 4, 2015 at 20:38
  • It's been a long time since I used shared hosting. Are you sure you can get root access on that? I never could on any host I ever used.
    – Rob
    Jun 5, 2015 at 12:01
  • 1
    @Rob No, I’m sure you cannot get root access. But you don’t need root access to run programs. However, the user data partition could be mounted noexec.
    – Daniel B
    Jun 5, 2015 at 12:37

If you visit the 1&1 site, and put your mouse over the word "servers", you will see "Dedicated server" along with "High Performance server with Full root access". Therefore, a dedicated server is what you need to login as root.

Like the people above said, because you're unfamiliar with linux commands, it suggests to me you might not understand the command-line well.

Start here and browse their knowledge base to see if there's a way via their control panels to add additional software. Visit:


And if that does not help you, then you need to talk to the people directly and ask them to install the packages you need installed and provide an excellent reason. Visit:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.