0

Recently the browser prompt insecure content warning while one of my colleagues visit our site using ie11 (It works well in my ie11 browser). But we are using all https protocol in our site. Anyone else encounter this situation? how do you fix this?

2
  • See if this throws up anything : whynopadlock.com
    – user29671
    Jun 3, 2015 at 5:39
  • A screenshot of warning page would be helpful. Mixed content is common scenario, but maybe there's something else.
    – lucgenti
    Jun 3, 2015 at 7:41

1 Answer 1

1

Security warnings usually happen if one of your pages has linked resources through insecure protocol. It's called "mixed content".

Use some tools like https://www.jitbit.com/sslcheck/ for crawling your website and find the culprit.

Remember to make all your links relative like this <img src="//www.example.com/example.jpg" alt="" />

If that's the reason, you may display webpages without warnings because you have enabled "Display mixed content" in your IE11.

2
  • my relative links are all like this <code> <img src="/static/example.png" alt=""> </code> , that`s the reason? Jun 4, 2015 at 2:12
  • That's a valid relative URL. Keep it. Post a screenshot or the details of the warning.
    – lucgenti
    Jun 4, 2015 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.