1

Wondering if anyone has seen this before, where on Exim 4.85 an email password fails because it had an & in it?

As you can imagine it took ages to get to the bottom of what was going on. Kept resetting customer's password, it kept failing.

Then I had an idea and put a pretty simple password and it succeeded. So went back to the original password which was something like Jumpy05#&* and working with the customer logging into webmail, started building the password

Jumpy05 - worked
Jumpy05# - worked
Jumpy05#& - failed!

Aha!!! Talk about obscure.

But the important question is why? Anyone seen this before? Is there a setting somewhere to override this?

I suspect it has something to do with & being part of querystrings, but am not sure. Ideas or solutions welcome.

  • 1
    Can you give us the name and version of the email server/application ? – John McNamara May 29 '15 at 1:01
  • 1
    Mailserver is Exim 4.85 – Steve May 29 '15 at 1:11
  • 1
    ok, and what interface is the password being typed into ? Possible examples would be "bash prompt", "cPanel", "custom written php web interface", some java app etc etc etc. – John McNamara May 29 '15 at 1:15
  • 1
    @JohnMcNamara it was happening with cpanel webmail and also her mac mail client. So it seems to have been a general issue, not a client issue as far as I can tell. – Steve May 29 '15 at 1:43
  • 1
    Well I have now done some tests on a couple of mail accounts and can't recreate it. However it was most certainly happening the other day. Perhaps it is an encoding thing, who knows. I think the mystery will never be solved. But at least I might now get the tumbleweed badge :o) – Steve May 30 '15 at 1:37
1

This is a common issue with most scripting and/or framework because the ampersand (&) references a variable in the source code. Similar unsupported characters may also include brackets ( [ ] ) or angle brackets ( < > ).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.