1

I add a site to Cloudflare and try activate flexible SSL plan for it.I was able to add SSL by adding page rules to main domain (example.com) and www as well.It's working nicely and browser shows https also.Then I added SSL to subdomain of my domain "blog" (blog.example.com).But it's not working.

I activate SSL for subdomain by giving URL patter as " *.example.com".

How can I resolve this thing ?

Thanks !

migrated from webapps.stackexchange.com May 21 '15 at 23:37

This question came from our site for power users of web applications.

  • CloudFlare's SSL should cover one level of subdomains as covered here, however, you should be setting up your subdomain(s) in their DNS, not with PageRules, so they can be added to their SAN, which likely takes time to reflect any changes. – dan May 22 '15 at 3:31
1

Got it solved.That directory which is forwarded my subdomain consist wordpress blog.It happens like this because of mixed content issue.

Here is the solution.

https://blog.cloudflare.com/flexible-ssl-wordpress-fixing-mixed-content-errors/

  • 1
    Thanks for adding a followup answer. You probably were receiving a mixed content error in that case (e.g., a lock with a line). Can you edit the question to reflect that instead of just "not working" so that it might be helpful to others in the future? Thanks. – dan May 22 '15 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.