I have a hotel site which links out to Synxis for our booking engine and then once the booking is complete, passes the user back to our hotel domain to continue browsing. I have got ecommerce data reporting correctly and have followed the instructions on the Analytics dev site to implement cross domain tracking. For some reason, I am still getting my primary domain showing as our primary referrer.

The code on each site is:

    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),

    ga('create', '{google-analytics-code}', 'auto', {'allowLinker': true});
    ga('require', 'linker');
    ga('linker:autoLink', ['synxis.com'], false, true);
    ga('send', 'pageview');

Obviously in the code on Synxis I have the autolinker set to the hotel domain.

In analytics, I have set the referrer exclusion list to include hotel.com and synxis.com. From the docs I gather this should cover the actual subdomains the users visit (i.e. www.hotel.com and gc.synxis.com).

For some reason, when I debug the analytics, it looks like when I leave the primary domain, my hotel site is listed as the referrer (when I go back from Synxis to the hotel the referrer field does not show in the console). It seems to be decorating the links as it should and there is no missing analytics code on any pages (the CMS ensures this). Our domain is http and the Synxis portal is https (not sure if this makes a difference).

Any ideas?

  • 1
    Unless someone can tell me definitively how referral exclusion checks sub domains, I always add www. as well as without (ie. hotel.com and www.hotel.com), just to be safe. – nyuen May 20 '15 at 13:35
  • Thanks, if updating the shell doesn't work will add the sub-domains into the referral list as suggested. Can't hurt. – Luke Murray May 20 '15 at 16:46
  • I am having the same problem for years and hoped that with the change to UNIVERSAL was solved. But it never did. – user52632 May 22 '15 at 8:49

Realised from the referral details in GA that the issue is caused by Synxis using a different shell template for mobile users. I didn't have the Mobile setting in my admin section so didn't realise. Hopefully when I get the code updated this should cure the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.