1

Inside my website tag <head> part code like below and recently I get some error report from 'Google Webmaster Tools → International Targeting':

en - no return tags
es - no return tags

I googled but still can't get what "no return tags" means?

I checked the URL http://example.com/?hl=en work in my website route enable to get content.
Or does that mean there must have a dom <a> href and same as the language URL inside my <body> content?

<head>
  <!-- … -->
  <link href="http://domain.com/" rel="canonical">
  <link href="http://domain.com/" hreflang="x-default" rel="alternate">
  <link href="http://domain.com/?hl=en" hreflang="en" rel="alternate">
  <link href="http://domain.com/?hl=es" hreflang="es" rel="alternate">
</head>
  • 2 questions, how long have you waited for the changes to take effect in Google Webmaster Tools, and two is http://yourdomain.com/?hl=es accessible manually. – Simon Hayter May 17 '15 at 18:50
  • thanks for reply, 1 the code I added at 5/1, and the message shows craw date some is 5/5 and 5/7 and 5/14. 2 what is accessible manually mean? yes I added in html file – user1775888 May 17 '15 at 18:58
  • Whats your site address? – Simon Hayter May 17 '15 at 19:16
  • and does the HTML code of each page after the doctype begin with <html lang="xx"> where xx is the language code of the page you're editing? For example, xx should be "en" for all the pages written in english. – Mike -- No longer here May 18 '15 at 2:42
  • @Mike do you mean if user visit http://domain.com/?hl=en the <html lang="en"> , and if visit http://domain.com/?hl=es I also have to change <html lang="es"> this is why I get error message? – user1775888 May 18 '15 at 7:55
1

The warning means that the pages you are linking to do not have hreflang tags pointing back to the URL listed.

hreflang tags are bidirectional by nature, every time you link to a URL with hreflang tags, that URL must in turn link back to the original URL.

e.g:

If on this URL: http://domain.com/

You have these tags in your code:

<link href="http://domain.com/" rel="canonical">
<link href="http://domain.com/" hreflang="x-default" rel="alternate">
<link href="http://domain.com/?hl=en" hreflang="en" rel="alternate">
<link href="http://domain.com/?hl=es" hreflang="es" rel="alternate">

Then on this URL http://domain.com/?hl=en

You must have at least the following tags implemented:

<link href="http://domain.com/?hl=en" hreflang="en" rel="alternate">
<link href="http://domain.com/?hl=es" hreflang="es" rel="alternate">
<link href="http://domain.com/" hreflang="x-default" rel="alternate">

and on this URL http://domain.com/?hl=es

You must have at least the following tags implemented:

<link href="http://domain.com/?hl=es" hreflang="es" rel="alternate">
<link href="http://domain.com/?hl=en" hreflang="en" rel="alternate">
<link href="http://domain.com/" hreflang="x-default" rel="alternate">

If you do have these tags present, make sure the URLs are crawlable by Google. e.g they aren't blocked in robots.txt, or they no not have the robots NOINDEX tags, or they do not have a canonical tag referencing a different URL than themselves.

If none of these issues are present, Google just need to re-crawl the URLS. Issues in Webmaster Tools are notorious for being out of date.

Also you might like to note that Google recommends against using URL parameters for different language version of pages, you can read more here:

Multi-regional and multilingual sites and Use hreflang for language and regional URLs

| improve this answer | |
  • ... I did that already 1 those link tag same on each url 2 they aren't blocked 3 have same canonical point to no parameter – user1775888 May 18 '15 at 8:12
  • It could be that Google cannot crawl the URLs with parameters correctly. Have you checked if they URLs are indexed in Google? If so check Google'e cache of the URLs, view the source code of the cached page and see if the tags appear. – Max May 18 '15 at 8:13
  • You need to remove the canonical tag that points to the singe URL. Doing that you are telling Google to ignore the URLs with the parameters and to count them as a single URL. Either define a canonical tag pointing to the themselves (with the parameters) or have no canonical tag. – Max May 18 '15 at 8:15
  • but please check the source code play.google.com/… google use the the canonical tag too – user1775888 May 18 '15 at 8:18
  • and not all the page have lang parameter be indexed but in webmaster tools > URL Parameters already has lang – user1775888 May 18 '15 at 8:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.