0

I'm uploading and modifying files on my Apache 2 server via FileZilla and after I perform any action, the connection times out after five seconds, so it keeps having to reconnect every time I perform another action.

I know this is because of the KeepAlive, MaxKeepAliveRequests, and KeepAliveTimeout settings in apache2.conf, but I'm confused about exactly how they work.

KeepAlive is on, MaxKeepAliveRequests is 100, and KeepAliveTimeout is 5. I'm assuming the timeout setting is the one that kicks me off after five seconds, so is there any way to disable the timeout? I read somewhere that setting it to a high number is bad. Is 0 a possible value for this?

0

You are confusing the Apache web server with the servers FTP service, they are different services using a different communication protocol (FTP vs HTTP).
For example, when was the last time you went and read a wikipedia article, or performed a google search using Filezilla?
The keep alive directive is an Apache core directive for maintaining long lived HTTP (web content) connections and TCP connections that take advantage of the HTTP1.1 multiplexing features.
From the docs:

The Keep-Alive extension to HTTP/1.0 and the persistent connection feature of HTTP/1.1 provide long-lived HTTP sessions which allow multiple requests to be sent over the same TCP connection. In some cases this has been shown to result in an almost 50% speedup in latency times for HTML documents with many images.

Im not sure what is causing your timeout problem, but I wouldn't be looking into apache config to try and fix

  • Thanks for the pointer. It turned out to be the basic keep alive option FileZilla has. I don't know why I didn't see it earlier. – Adam May 17 '15 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.