0

I own a website that will be updated daily with clients. When I upload new info/web pages/amendments, the old cached version of the 1st page keeps popping up. How do I stop this....

  • Cached by what? Questions about webmaster concerns about search engines belongs on Webmasters. – Al E. May 7 '15 at 11:02
1

If you're referring to caching from the way google looks at it, then use the robots noarchive tag like this:

<meta name="robots" content="noarchive">

If you're referring to browser caching (which I think is the case), then configure your server to issue the following in the HTTP header for each page you don't want cached.

cache-control: no-cache,no-store,must-revalidate

If you're serving older browsers that only understand HTTP 1.0, then use the following in the HTTP header:

pragma: no-cache

If the pages of your website are generated on the fly with PHP, then you can easily add those headers with this command:

header(____,true);

Where the ____ is replaced with each header to include.

The only other option is to have everyone turn off caching in their browsers, but that will not likely happen.

0

For Google search results, have a look at the 'Meta tags that Google understands'

You can use

noarchive: prevents Google from showing the Cached link for a page.

nosnippet: prevents a snippet from being shown in the search results

Using both of these tags will mean your site will just display the title though Google will still show whatever title was on the page when last crawled.

-1

You need to set some META tags in the pages you don't want cached.

Have a look at the CACHE-CONTROL & EXPIRES tags here which control browser caching.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy