1

I have a VPS running Plesk (v11.5.30), on which I have multiple domains. I've found that I am having problems with emails sent from this server being tagged as spam.

On running a test with www.mail-tester.com

I get the following response:

We check if there is a mail server (A Record) behind your hostname localhost.localdomain.
You may want to publish a DNS record (A type) for the hostname localhost.localdomain or use a different hostname in your mail software.

Looking through my settings in Plesk I realise that I have the full host name (Set in Server Management -> Tools & Settings -> General Settings -> Server Settings) set to localhost.localdomain

My question is what should I set this to if I have multiple domains and would resetting it now fix my problem or has this value just been copied to somewhere in the mail system config files?

1

I'm answering my own question here in case it helps anyone else.

Your hosting company should be able to provide you with the full name of your vps. It's probably visible somewhere in your control panel if you don't log direct into Plesk and is likely to be something like:

858442.vps-312.com

or

8abc-arc.yourdomain.com

Setting this to your full server name should fix this problem and (in my case at least) didn't effect any existing services.

On testing with www.mail-tester.com this changed by existing error:

We check if there is a mail server (A Record) behind your hostname localhost.localdomain.
You may want to publish a DNS record (A type) for the hostname localhost.localdomain or use a different hostname in your mail software.

to

Your hostname 858442.vps-312.com is assigned to a mail server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.