We are having trouble getting the category name into the URL.

We want to use the following structure:


For some reason our wordpress theme (HelpGuru) is not pulling these changes through.

Is there any way to override the theme's settings and force the URL to include the Category?

  • It seems that actually the best way to go is NOT to have the category in the URL. In another similar post there is some excellent input. In this case, the best way to go in terms of SEO is to have example.com/knowledge-base/short-descriptive-article-name
    – walbuc
    Mar 31, 2015 at 13:51

1 Answer 1


This is not an issue generated by the theme, in order to add categories into you URL you'll need to to change your URL structure. In order to do this you'll need to navigate to:

wp-admin => Settings => Permalink

Where you'll find a section like this:

By selecting the Custom Structure option you can modify your URL the way you want, for example:

  • Custom Structure - http:// domain.com /%year%/%monthnum%/%postname%/

In this case, what you need is add the %category% to this input, for example:

  • Custom Structure - http:// domain.com %category%/%postname%/

Please note:

You never, ever put your site url in the permalinks slot. You must use one of the structure tags, or a combination of tags only.

You can use a variety of tags here, check them out on https://codex.wordpress.org/Using_Permalinks

  • 1
    We have already tried this but the theme is overriding the WordPress settings. We have been in touch with the theme owners to address the issue which seems to be a bug on their side.
    – walbuc
    Apr 8, 2015 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.