1

I have a complex web page that I created in an n-tiered environment. Users can use drop down menus to create their own customized graphs. The graphs aren't appearing all of a sudden.

Users get this message: "Windows has blocked this software because it can't verify the publisher."

The problem is 100% reproducible. I made the URL a Trusted Site in Internet Explorer 9. The website doesn't support browsers besides I.E. I enabled every ActiveX setting (to maximize usability at the potential expense of security). But the graph still doesn't appear. I reduced the UAC to its lease secure setting. The graph still won't appear. What might be wrong?

The problem may be at the server level. I'm using HTML, JavaScript, CSS, Java, and other technologies. Logging in requires a username and password. Most of the web page is working. The place where the graph would be shows an un-downloaded picture. This error correlates with the lack of the graph after the user selects menu options prior to its generation.

migrated from webapps.stackexchange.com Mar 22 '15 at 13:22

This question came from our site for power users of web applications.

  • Fiddler showed that the ingress and egress ports involved in the transmission of the graph of the web page (e.g., trying to get the graph to be displayed packets are sent and downloading the customized graph involves receiving packets). That is, rather than use the same ingress and egress ports for the configuration of the graph and rendering it, the ports were different every time I reproduced the problem. None of the ports were port 80. – Yousef Mar 22 '15 at 17:45
  • IIS supports the website service. IIS logs have nothing about "certificate." The logs didn't seem to tell me much. – Yousef Mar 24 '15 at 3:27
1

This happens if Internet Explorer is not configured to let you install unverified software. A quick and dirty fix for the problem is to open up the internet options window and select custom level for your security settings. Under ActiveX ensure the following settings are set to enabled...

  • Run ActiveX and Plugin's
  • Download Signed ActiveX Controls
  • Script ActiveX Controls Marked as Safe For Scripting

And set the following settings to prompt...

  • Download Unsigned ActiveX Controls
  • Initialize and Script ActiveX Controls Not Marked As Safe

If this still isn't working then there is more than likely a network security filter in place which overrides the less secure behaviour and forces the ActiveX controls to be blocked. The other way to deal with this is to digitally sign your ActiveX components. How to digitally sign your ActiveX components is a little beyond the scope of this answer but Microsoft provides very useful information on this at https://msdn.microsoft.com/en-us/library/aa231196(v=vs.60).aspx.

I should however point out that Microsoft has dropped ActiveX support from the Windows Store edition of Internet Explorer 10 in Windows 8. and in 2015 Microsoft Edge which is the replacement for Internet Explorer dropped ActiveX support which means that moving forward ActiveX will not be supported on the more recent versions of Internet Explorer and that attempting to continue to use it will open up issues with forward compatibility with more recent versions of IE and Edge. I would strongly recommend migrating your graphing tools away from ActiveX and converting to technology that will be around for longer such as Flash Graphs, javascript charts, and even SVG based charts.


https://blogs.windows.com/msedgedev/2015/05/06/a-break-from-the-past-part-2-saying-goodbye-to-activex-vbscript-attachevent/


http://www.computerworld.com/article/2920892/web-browsers/microsoft-nixes-activex-add-on-technology-in-new-edge-browser.html


https://en.wikipedia.org/wiki/ActiveX

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.