3

Using Firefox got this error: "The server rejected the handshake because the client downgraded to a lower TLS version than the server supports. (Error code: ssl_error_inappropriate_fallback_alert)"

First fix attempt was to invoke about:config and set security. tls.version.min to 1, but it was already set to 1.

Maybe I should uninstall/reinstall Firefox? Has anyone ever experienced this?

  • yes - same issue still trying to solve it. Started noticing sites clocking longer than normal before loading. I was able to access Bank of America (my issue site) from Windows7 safe mode without any issues. Returning to normal mode allowed access one time then nada. – user50820 Mar 23 '15 at 19:16
1

For me, the problem was solved when I disabled "SSL scanning" in BitDefender (BD Antivirus Plus 2015). It worked instantly.

1

Cache may have been the issue. At the command line I typed ipcofig /release then a few seconds later ipconfig /renew . That may have been enough.

However, I also typed ipconfig /dnsflush . All good after that.

  • That's assuming the user is on Windows. – Andrew Lott Apr 21 '15 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.