1

This problem does not happen to all site visitors. The best I can tell, random users of Chrome have the issue but my sample size is way too small to believe that it is only Chrome. However, a few people that have the problem with Chrome do not have it with other browsers. It has happened on PCs and Macs.

I had a few reports of the problem, than all of a sudden it started happening to me. I turned off Cloudflare and the problem immediately stopped. Right now I have to keep Cloudflare off, so there is no point to posting the URL.

This is a new site with an SSL cert. In case it's helpful, here's the .htaccess redirects:

RewriteEngine on
RewriteCond %{HTTP_HOST} ^example.com\.com$ [OR]
RewriteCond %{HTTPS} !on
RewriteRule ^(.*)$ https://www.example.com/$1 [R,L]

All advice appreciated.

  • Are you trying to redirect all access from HTTP to HTTPS?? – closetnoc Mar 4 '15 at 23:14
  • Under CloudFlare Settings, make sure you have SSL set to Full and not the default Flexible, since you have an SSL certificate on the origin server. Also, please edit the question to let us know what your www record points to in CloudFlare and in your default DNS provider (they should be the same). You might try the first rewrite here to help sort out any loop redirects occurring between www and non-www. Last but not least, make sure you don't have any Page Rules in CloudFlare setup that might result in a loop. – dan Mar 5 '15 at 1:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.