0

We're migrating from an ASP.NET website to a WordPress website, hosted on IIS (don't ask). There's a few things we need to migrate over, and for the most part I can get away with a simple HTTP redirect.

One of the Web Services I need to migrate is 'SQL Server Compact 3.5 Server Tools' (https://msdn.microsoft.com/en-us/library/bb986820.aspx) - essentially this is a DLL called sqlcesa35.dll. I've set this web service up several times so know what I'm doing, plus it's currently working on the same IIS server, within a different website (the original ASP.NET website).

However, I can't get it to work as an application within the WordPress site. I have no experience with WordPress, so don't really know where to go next. The error I get when I attempt to access the DLL are: HTTP Error 500.50 - URL Rewrite Module Error. Most likely causes:

•IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.

•IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.

•IIS was not able to process configuration for the Web site or application.

•The authenticated user does not have permission to use this DLL.

•The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.

Quite a few things to target, but I'm confident it isn't permissions.

Is it possible to achieve what I'm attempting, as I'm starting to wonder if there's something fundamental I've overlooked? Thanks

Edit: The wordpress site has .dll disabled, in handler mapping, however the sub-application has .dll enabled. Will this be an issue?

  • The error message is pointing to the URL Rewrite module. Since you feel confident that the permissions on the directory are correct, can you update your question with the relevant part of your web.config? Have you also tried removing the rewrite rules for the WordPress site to see the service is available? – James Skemp Feb 22 '15 at 1:14
  • Hi James, one thing I did try was temporarily removing the web.config and accessing the link but this didn't work either :/ – kafka Feb 23 '15 at 9:29
  • Then I would recommend double checking the permissions. I'm also looking at your edit again; so you have your WordPress site set as an application (or site), and then within that you have a directory converted to an application? If you setup a new site that points to that directory, does that work? The handler mappings shouldn't matter, since you have a sub-application setup. – James Skemp Feb 23 '15 at 13:12
0

This has been fixed. The solution was to modify the Application Pool, and set 'Enable 32-Bit Applications' to True, so not related to WordPress etc.

  • Glad you figured it out! FYI, you should be able to mark this as your answer so it doesn't show up in the unanswered listing. – James Skemp Feb 24 '15 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.