2

We use the Yoast SEO tool for Wordpress, and a recent feature added the SearchAction meta tags to allow for sitesearch on the google search results page.

After a while, I realized that this tool was putting in the wrong code/path, and I updated our site to use what we wanted. This has been a few weeks though, and it still hasn't been updated on Google.

While I know we are at the mercy of the Google index, is there any way to force this through webmaster tools?

1

If Google indexed the wrong code/path, use the "Fetch as Google" function in Google Webmaster Toolkit with the URL where you have the Sitesearch snippet and the click on "Submit to index".

This is confirmed to work - more info also on my blog on how to track the usage - http://www.naschenweng.info/2015/03/04/google-sitelink-search-box-how-to-implement-proper-usage-tracking/

FWIW: The initial SSB snippet was picked up in 2-3 weeks, but the change to track via campaign parameters was indexed within a few days.

0

For reference, here is Google's documentation for the markup needed to enable search within your site from site links. They don't mention anything about how quickly they would react to changes.

It may end up taking Google a long time to update. You should be able to put redirects on your site to correct for the mistake until Google gets it updated. If you have the wrong path (lets say you told Google it was /search when it really should be /search.php then you should be able to redirect from one to the other with the following rewrite rule:

RewriteEngine on
RewriteRule ^search?$ /search.php [R=301,L,NC,QSA]

The QSA is important. It means "query string append." Without it, the search parameter wouldn't be part of the redirect. The rule can be put directly into the top of your .htaccess file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.