2

Note : Asked this question on wordpress.stackexchange.com, it was recommended to ask here.

I am trying to get webmastertools to verify my ownership on my domain. www.swipetelecom.com.

Issue : When I try to reach the googlewebmastertools.html file, using http://www.swipetelecom.com/googlewebmasterstools.html. I get a 404

Not Found

The requested URL /googlewebmasterstools.html was not found on this server.

But : I am able to reach the googlewebmasterstools.html file using the 1.2.3.4/wordpress/googlemastertools.html.

I am using a local domain manager (not godaddy). I have setup Frame Forwarding at the domain manager. Does it have something to do with this ?

This is my .htaccess (in my /var/www/html/wordpress folder), does it have anything to do with this ?

<IfModule mod_deflate.c>
    <IfModule mod_headers.c>
        Header append Vary User-Agent env=!dont-vary
    </IfModule>
    <IfModule mod_filter.c>
        AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
    <IfModule mod_mime.c>
        # DEFLATE by extension
        AddOutputFilter DEFLATE js css htm html xml
    </IfModule>
    </IfModule>
</IfModule>
# END W3TC Browser Cache
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

My wordpress folder and all their contents are owned by www-data.

What am I missing here ?

And yes, I have tried all other methods of verification, but none of them work too. This is the most logical question I could ask here.

10
  • I able to access site and home page running fine..inner pages are not working I think , right? – Helping Hands Feb 5 '15 at 11:14
  • Yes, The website is working perfectly fine. But inner pages are not. – Siddharth Feb 5 '15 at 11:17
  • do you able to access wp-admin? – Helping Hands Feb 5 '15 at 11:17
  • Yes, I am able to access admin pages, I am able to view the website. I am also able to see that googlewebmaster html file using the ipaddress. Just via the DNS the file is not visible. – Siddharth Feb 5 '15 at 11:18
  • So issue is you are not able to access googlewebmaster pages OR your site inner pages? – Helping Hands Feb 5 '15 at 11:20
2

Frames will not do what you are trying to achieve. You are iframing content from another server/ip (server 2) which is completely separate from the server/ip (server 1) hosting your index page with the frame on it. So since you have your Google verification file on server 2 you will be unable to call that path from server 1 since nothing is actually located there.

I would recommend making /wordpress/ the web root for server 2 then just changing your A record for swipetelecom.com to 54.169.149.94 from 180.149.240.169.

Alternatively you could just upload your Google verification file to server 1 (180.149.240.169).

6
  • Can I just change the A record of swipetelecom.com to 54.169.149.94/wordpress ? Since if I do what you are saying I will also have to edit .htaccess ? – Siddharth Feb 5 '15 at 16:37
  • I have a option to use "Standard Forwarding". But the description of this type of forwarding is not clear. Redirect website visitors to another site and show them the destination address. Use the 301 code if you moved the site permanently to this address - such redirection will keep the site's search engines rankings. The code 302 can be used to redirect visitors to a temporary site copy, when you do not want search engines to index this temporary site. – Siddharth Feb 5 '15 at 16:41
  • DNS is oblivious to any paths or port numbers, it only turns names into ip addresses so you would be unable to set the A record to "54.169.149.94/wordpress". Though i still suggest charging the A record to "54.169.149.94" because i don't really see the point in the current setup and framing. After the domain is pointed to server 2 you could either just upload an index.php file to the web root and make it auto redirect to /wordpress but then you will constantly see www.swipetelecom.com/wordpress which isn't as pretty as just www.swipetelecom.com. 1/2 – Analog Feb 6 '15 at 3:03
  • If you have full access to server 2 you can just edit the Apache webserver config to change the webroot to /wordpress. 2/2 – Analog Feb 6 '15 at 3:06
  • Ok, I'll make the change on the A record also change the webroot to /wordpress. Should I also change my DNS forwarding to Standard Forwarding from the current Frame Forwarding ? – Siddharth Feb 6 '15 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.