2

I am trying to use Google Analytics to track various AdWords combinations. good old A/B testing :-)

The documentation isn't great, so I tried to set utm_content to track the advert text. This didn't work - I eventually found (and have since demonstrated to myself) that this is because I had auto-tagging switched on in AdWords.

When I switch auto-tagging off, I can track individual ad text, but not things like keywords. Also every URL needs a lot of tag parameters which is difficult to manage.

Auto-tagging fills out all these tags automatically without the chance of error, and also adds additional tags which could be useful later. Great! The only problem is that it fills the utm_content tag with the advert's title. I need finer tracking. For example I have two adverts in the same ad group with the same title but differences in the main ad text.

Is it possible to use auto-tagging and add a 'custom' tagging dimension, or to override utm_content?

3

The easiest way here is to use the so called ValueTrack parameters in association with the tracking template. Those two features of Adwords let you define a tracking template which will dynamically replace the final url every time your ad is clicked to match the parameters you had specified in this template.

In your specific case you should

  1. Create a tracking template at campaign or account level (https://support.google.com/adwords/answer/6305348)
  2. Use {lpurl}?utm_content={creative} with {lpurl} representing your destination url and {creative} being the precise ID of your ad
  3. Enable UTM overriding by going to your Google Analytics account > Admin > Property > Property Settings > Advanced Settings > Allow manual tagging (UTM values) to override auto-tagging (GCLID values)
  4. Add the Ad ID to the the set of columns you use on Adwords

The other method is to:

  1. set up a tracking template with the following parameters at account level {lpurl}?utm_content={_adcontent}, feel free to use anything you want instead of adcontent as long as it's not one of the standard ValueTrack parameters and make sure that it's preceded by _
  2. When you create an ad go to Ad URL options (advanced)
  3. Under Custom parameter enter the name you have previously used like adcontent, don't include the underscore _ as it's already included
  4. In the value field enter a meaningful description of your ad, making sure that it's url encoded so for instance if you wanted the best kitten in the world to appear in Google Analytics you should use the+best+kitten+in+the+world
1

It would appear the answer is hidden away in the various settings, but in Google Analytics (rather than Google AdWords), on the Property->Advanced Settings, there's a checkbox for Allow manual tagging (UTM values) to override auto-tagging (GCLID values), and this needs to be set. In addition, auto-tagging (in Google AdWords) needs to be enabled.

I've just made these changes and we shall see if it collects the data as expected...

  • Unfortunately this does not appear to be working. Google Analytics is showing the ad title as the content. – winwaed Jan 20 '15 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.