2

I installed Question2answer on my paid server. After I published a post/question on my Question2answer site I tried to edit it, but when I was trying to save the post, it outputs an error that says:

Forbidden

You don't have permission to access 3/theres-music-everywhere on this server

(3/theres-music-everywhere is the URL of the post/question)

I thought this was a server problem so I asked the server's support team and they told me that this is a problem with my script and they cannot help me. I also asked on Question2answer platform, and no success at all. How can I fix this? Editing posts is a very important function.

I'm hosting my Q2A script on Hostinger.pt servers (or hostinger.co.uk If you prefer I think they are the same.) I think these are Apache servers not really sure

  • This is likely a directory/file permissions issue. I do not know Question2answer. Recheck the install instructions for anything you may have missed. Also stick with their online forum. You can also check the Apache access/error log files for the exact error. This may give more of a clue. – closetnoc Dec 10 '14 at 22:49
  • I searched the web a bit and did not find anything I could link to. Sorry. I invite you to look in your Apache access/error log files for related messages and add them to your question here. With a bit of back and forth, I am sure someone(s) here can solve this for you. But as it stands, there is not enough information to answer your question. We would need more information. – closetnoc Dec 11 '14 at 0:07
  • Hey @closetnoc thanks for the response I went to the 'Error log files' directory in my Cpanel and I hit show logs and it only showed me this: Bad file!. Here's what I'm gonna do, there's a thing here on the Cpan that says 'Repair Files Permissions' I'm going to try do that and if still doesn't fix the problem I'll try to make a backup of my files and database and do the "Reload Account" which I think it resets my account as original and then I'll get back to you with the news – Chun Dec 11 '14 at 0:36
  • Sounds good to me. If I am not here, this sounds like something that can be fixed by someone who knows Linux. – closetnoc Dec 11 '14 at 0:41
  • I just did the "Reload Account" option and re-installed the script with new fresh database and all, but it's still doing the same thing :\ – Chun Dec 11 '14 at 1:36
1

You will need to modify your read-write access permissions I am guessing. Log into the server, get the file in question >click click > edit permissions > chmod 644 would probably be the way to go.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.