11

The page I'm trying to fetch is public. The server logs show no request. Google reports that any page on my site is "Temporarily unreachable". It won't even fetch the verification file, a static HTML file that was successfully used to verify with the webmaster tool application itself.

My site is running on the Google app engine.

What is causing this?

7

According to Google, it's because:

  1. Fetch as Google can't currently fetch your URL because the server took too long to reply.
  2. Or Fetch as Google cancelled your fetch because too many consecutive requests were made to the server for different URLs.

I've witnessed this happening a few times in the past. More often than not, it's an intermittent problem that goes away after a short period of time.

Important note:

Note the URL is not unreachable for all of Google - It is just unreachable for the Fetch as Google simulation tool.

  • Thanks. Although the solution seems to be wait ? There is not even a request registered on my logs (which are accurate as they run on google app engine). – NimChimpsky Oct 3 '14 at 14:13
  • 1
    If there are no requests in your log, then it could be a case that the tool is overloaded. – Wexford Oct 3 '14 at 14:41
  • Why didn't you include any links for your quotes? – Buttle Butkus Oct 5 '15 at 23:47
2

Old thread but I had this issue, it was due to making changes on cloudflare supported TLS version. Google does not support tls 1.3 yet - make sure your servers allows tls 1.2

1

check htaccess and dns server connectivity. this often occurs in shared hosting. Besides, htaccess has been created before we upload our web file in shared hosting. try to check both of items. If OK in htaccess, then you should contact your host.

1

Another cause can be because you have recently moved to another hosting server, you have just changed DNS servers

1

I found the answer (that worked for me) here: https://productforums.google.com/forum/#!topic/webmasters/IomjijWoCfU

See Tracy Brown 4's reply (found about 90% of the way down the thread):

You dont have a robots.txt file. Google appears not to fetch in WMT if there is no robots file.

I added an empty robots.txt file, immediately tried again, and it worked.

0

I'm not sure if it's 100% the same issue, but recently I tried using the fetch as google page in Firefox, not Chrome, and it suddenly decided that my most recent 'temporarily unavailable' request was actually a 'partial' success. Very strange, but it seems to work a bit more now.

0

I've faced same problem and when i deactivate wordfence then fetch and render it shows me successful status

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.