1

I recently installed WAMP, and started developing on its Apache server. Given that my text editor (Sublime) didn't have permissions to write on C disk directly, I changed my default DocumentRoot to My Docs/www and everything was working fine (except that any site with .htaccess did not work).

I decided then to make virtual Hosts to solve this problem, but even localhost returns a 403 (and everything else).

Anyone knows why and how to reconfigure everything? (or how to give Sublime rights?)

1

Depending on what Apache version your WAMP is using, you may need to replace these directives in your regular virtual host settings:

Order allow,deny
Allow from all

with

Require all granted

Please see more about upgrading form Apache 2.2 to Apache 2.4 here.

0

I had the 403 error and this bit solved it.

Require all granted

I was almost ready to give up on virtual hosts with Wamp. Although I had read 2-3 blogs I missed this option. Also on my browser it was using google search in URL bar so I had to type http:// before the server name the first time I typed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.