0

I'm running an Ubuntu 12.04 server with Plesk 12, Apache 2.2.22 and PHP 5.3.10. I want to enable reCaptcha for my phpBB board, but every time I get this error: Could not open socket

I've enabled allow_url_fopen for this domain and temporarily allowed outgoing traffic on port 80 and 443 for all IPs. According to phpinfo() allow_url_fopen is enabled.

1

Judging from the question here, a similar problem was fixed by changing:

define("RECAPTCHA_VERIFY_SERVER", "www.google.com");

to:

define("RECAPTCHA_VERIFY_SERVER", gethostbyname("www.google.com"));

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.