2

This is really confusing to me.

Apparently you can set up multiple A records for your domain. And you do this by adding new A records to DNS editor/zone.

My hosting account grants me 5 IP addresses. Before there existed only 1 A record for my main IP. And that worked fine... when you entered my site's URL (with or without the "www"), you got to my site.

The thing is, I use all 5 IPs to send bulk email. The rDNS records for all my IPs link to my domain, but the forward DNS doesn't. So to fix that, I needed to create new A records for those IPs, right?

And so I did. And the names for all the A records were left blank, I didn't use "*", "@" or "www". That fixed the forward DNS issue for all my IPs.

The thing is, each time I went to my site's domain ("domain.com"), it returned this page: /cgi-sys/defaultwebpage.cgi

But when I entered "www.domain.com" it went to the correct page (my index page).

What I want to know is:

How can I enable forward DNS for all my IPs, while still being able to access my site without appending "www." to its URL?

How do I properly create the necessary A records?

  • You need to add a virtual host to your webserver corresponding to the domain.com. – Tero Kilkanen Aug 14 '14 at 19:13
  • Yeah it seems like you are missing the virtual hosts for whatever your a records are mail1.domain.com mail2.domain.com. If you post your whole dns records (edited to hide your domain) Id be happy to give you a full answer. – Frank Aug 14 '14 at 21:05
  • I am not sure why you added the extra IP addresses for e-mail. It was likely unnecessary. I would revert your settings back to where they were. – closetnoc Aug 14 '14 at 23:52
  • Thanks, guys. I think I have it sorted now. So don't worry about it Frank. Thanks. – Frank Jacobs Aug 16 '14 at 20:07
  • Since you have the problem sorted out, I'm closing this. I'm not sure what your solution actually was. – Stephen Ostermiller Aug 30 '14 at 10:30

Browse other questions tagged or ask your own question.