0

I simply trying to make my webpage come up as owncloud.example.com instead of owncloud.example.com/owncloud.

I am running Ubuntu 14.04 and Apache 2.4, and using OpenSSL. I have tried changing things in my apache.conf and conf-available, and I have changed the root directory to /var/www/ and put the first one in there without any luck.

  • Please show your configuration files. – Tero Kilkanen Jul 27 '14 at 23:37
0

The typical way to host a new domain or subdomain under Ubuntu/Debian is covered in this tutorial. Here are the basic steps:

  1. Create the file /etc/apache2/sites-available/owncloud.example.com.conf with contents based on this template:

    <VirtualHost *>
            ServerAdmin webmaster@example.com
            ServerName  owncloud.example.com
            DirectoryIndex index.html
            DocumentRoot /home/www/owncloud.example.com/htdocs/                
    </VirtualHost>
    
  2. Put your index.html and other files into /home/www/owncloud.example.com/htdocs/

  3. Run the command sudo a2ensite owncloud.example.com to enable the configuration for the site
  4. Run the command sudo service apache2 restart to restart the web server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.