0

I've changed my hosting provider today and bought a new host from another provider but i have this problem.


about my previous host: my previous hosting was also the one that registered my domain. they use resello company for domain registering. i asked them to change my name servers to the ones cloudflare gave me in order to use cloudflrare service. they did that, it worked fine.


my new hosting: i purchased a new host and there were some options about domains and i chose the one that was about changing only the DNS settings. so i had to change my domain's name servers to theirs so my domain will point to the new host


my problem: the thing is that i want my domain point to the new host, but i also want to use cloudflrare. i tried to change the main A record in cloudflare to point to the new shared address of new host but it didn't work. maybe it needs some time to change in cloudflare?

2
  • Please add an "Update" to your question instead of rewriting it so that existing answers will still make sense. i had to change my domain's name servers to theirs...i want my domain point to the new host, but i also want to use cloudflrare - your domain will need to point to the nameservers provided by CloudFlare, otherwise traffic will not be routed through CloudFlare.
    – dan
    Commented Jul 11, 2014 at 9:04
  • alright, well the problem was the empty htaccess file which blocked every request and i thought it'd have been included in the zipped backup file of cpanel.
    – user38723
    Commented Jul 11, 2014 at 9:33

1 Answer 1

2

So your explanation was really confusing, but your solution seems fairly simple:

Your domain's servers are already pointed to the cloudflare nameservers. You do not need to change these. Cloudflare is still pointing users to your old host, but you can edit the DNS records in cloudflare to point to your new host. Simply change the existing A record to point to the IP of your new host. You may also need to adjust your mail and other records.

3
  • updated my question i changed the ip address of the first A record which was my main domain to point to the new shared ip address but still doesn't work.
    – user38723
    Commented Jul 11, 2014 at 8:10
  • It's really just hard to envision your setup, if you could post a screenshot of DNS records on your cloudflare and your old hosting account that would help a lot. Commented Jul 11, 2014 at 16:50
  • thanks, the problem was the htaccess file which was empty and i just pointed the new ip to the cloudflare's DNS.
    – user38723
    Commented Jul 11, 2014 at 22:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.