2

I've recently changed a website to run only on HTTPS. HTTP connections are 301 redirected to HTTPS and a HSTS header (Strict-Transport-Security: max-age=31536000) has been added.

I've added the HTTPS version of the domain to both Google & Bing Webmaster Tools, but when I try to add it to Yandex Webmaster Tools it tells me the site is a mirror:

Yandex add a site

When I click the "add www.domain.com" link I then get a warning that the site redirects and I should instead add the HTTPS domain, which is what I've already tried:

Yandex add a site warning

Is there a way around this catch 22?

3

I actually ran into this same problem a few months back on a site which forces SSL. I contacted Yandex support directly about this so I'll share their response:

Hello,

Please accept my apologies for the delayed reply.

You should specify https domain as the main mirror in your robots.txt file and then wait for a couple of weeks ( http://help.yandex.com/webmaster/controlling-robot/robots-txt.xml#host ). When the main mirror changes according to your settings, your website will be able to start indexing and appear in search results at https protocol. You can find more information about the fact what websites are considered to be mirrors by Yandex on page http://help.yandex.com/webmaster/yandex-indexing/site-mirrors.xml .

-- Sincerely yours, Platon Yandex customer support http://company.yandex.com/

| improve this answer | |
0

It looks like Yandex have caught on to this and developed a workaround!

Yandex - Add a site

There's now a new option:

If the site was mistakenly considered a mirror, you should add https://www.domain.com and adjust the mirrors.

They also recommend using the Host directive in robots.txt once it's been added.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.