3

I have some pages on my website www.acethem.com which are having 301 redirection but they are not actually 301 redirects. e.g. www.acethem.com/pastpapers/by-year/2007/ is seen as a 301 redirection to www.acethem.com/pastpapers/by-year by google (I am using "Fetch as google" in webmaster tools.

Now more weird...

My paginated pages with page >= 10 are all redirected to homepage:

http://www.example.com/pastpapers/o-level/chemistry/page/10/

while

http://www.example.com/pastpapers/o-level/chemistry/page/9/

is working properly in the Google crawler.

Note that all these pages work fine with no redirect in browsers.

Sidenote: on www.example.com/pastpapers/by-year/2007/, the Facebook share button also points to www.example.com/pastpapers/by-year/.

  • Did you ever find out what is causing this? I have just encountered the same issues, any paginated page over 9 gets redirected to home page when the user agent is Google-Bot. – Max Jun 20 '15 at 7:16
  • @Max Were you perhaps hosted on WPengine, as a recent answer (below) suggests might be the cause? – MrWhite Feb 26 '19 at 23:32
3

If you simply click the URLs they do not redirect, however there is something set so when Google Bot hits the pages they do redirect.

I discovered this by using Screaming Frog Spider tool and changing the user agent to GoogleBot, then crawling the URLs you posted.

You can see the results below:

enter image description here

enter image description here

Not sure exactly what would cause this? You could post your .htaccess file to review to see if it's defined in there. Also try disabling your WordPress plugins one by one and see if it's a plugin causing the redirects.

|improve this answer|||||
2

For anyone who may have stumbled on this as I did in seeking out an answer to the same question, I'm going to guess you're hosted at WPengine.

If that's the case, simply login and open up a chat with support and tell them to turn off:

redirect bots

I wrote about the cause of the issue in a post here but if you're not interested in the full story, it ends with the solution noted above. :)

If you're not hosted with WPengine I, unfortunately, don't have a solution as I'd never seen it before either.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.