I'm trying to accomplish the rich snippet to the template of my future web-site. The data format is review and I used the microdata formatting to add all necessary information to the web-page. The Structured Data Testing Tool delivered rating, author information and review date:

enter image description here

However there is no my face image and the sections related to authorship are empty:

enter image description here

I made all that recommended to link my Google+ profile to the web-site:

enter image description here

I did something wrong? Or I will not be able to see my face in the test tools ever and it will be in the real SERP?

1 Answer 1


If it says the page does not contain authorship markup in the rich snippet testing tool then yes, you've done something wrong. Enter your Google+ profile URL in the box provided and see where the problem lies.

You need to link to your Google+ profile using syntax <a href="https://plus.google.com/NNNNNNNNNNNNNN?rel=author">Google Plus</a>

You won't be able to have review schema and authorship schema showing in your search result listings either - it will be one or the other. We've tried this before but I think Google only allow a limited amount of schema just so websites can't go overboard with their pages.

  • Thank you for the help. Couple comments: If I use my G+ account link and press 'Verify authorship' I just throw over to the beginning of the same page - no any additional message shown. You could try your self: plus.google.com/107295573220344975998 and digitalcameraport.com/item.php. The second part of your answer I just didn't understand. Could you chew it over? May 27, 2014 at 11:33
  • 1
    There isn't any authorship markup on /item.php - that's why the testing tool says it isn't there. You need to link to your Google+ profile using rel="author" for example. The second part just basically meant that you won't be able to have your Google+ picture and the star ratings visible in search results at the same time.
    – zigojacko
    May 27, 2014 at 12:24
  • Hmmm... I didn't find such information in the docs. However that worked! Thanks! May 27, 2014 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.