I've setup IIS locally to host a website. I've created a free NOIP account so I can access it with a domain name. It's temporary, so I plan to assign a real domain to it later. I setup port forwarding on the router. Everything is in place.

I spent hours yesterday trying to figure out why I can't access the website via my external IP / hostname. I can access it locally from the same machine using localhost. I can access it locally using another machine by using the IP address. But I can't use the hostname or external IP address. I believe it must be a router setting.

Today I attempted to access the site from another network, and it works just fine using both the public IP address as well as the hostname. However, from my home network, where I'm running this, I can't use the external IP to access the site; only the internal IP.

My question / concern

Based on all of the above I'm concerned that my provider (Comcast) might be blocking access in some way, though I wouldn't have a clue as to where to start to check. Is there any reason I shouldn't be able to use an external URL to access my site? It seems I should be able to use both the internal and external IP and get the same results.

Thoughts? Suggestions?


To attempt to rule out a server config / Windows issue, I wiped the box, installed Ubuntu on it, and just completed a LAMP installation. Unfortunately, it has the same issue. From within my home network I can access the web page with my internal IP address, but not the external IP or hostname. On another machine, outside my home network, I can access the webpage using the external IP and hostname.

I'm curious if others can access it also. If you don't mind trying and posting in the comments below, the temporary URL is http://cfsamet.noip.me. I'd be curious if anyone other than myself is having trouble accessing the site. It's the default Apache for Ubuntu page right now.

Update #2

No luck yet. Have tried to connect internally using my MacBook, Windows, Linux, even my iPhone. All fail when using the external IP or URL, but can connect fine if I use the internal IP address. I can only assume it's a router issue, or a Comcast issue... not sure I'll get much further here. I'm mostly just stumped at this point.

I've tested using http://www.gomeznetworks.com, all of their servers can access the site just fine. I've also tested using http://tools.pingdom.com. It can access the site as well. It seems that I'm the only one (from home) that can't access my site. How does that even make sense?? LOL.


Unfortunately, this was put on hold... but I did essentially find the answer to the problem. This is a hardware issue with the Comcast modem used. This link - http://forums.comcast.com/t5/Home-Networking-Router-WiFi/SMCD3G-Can-t-access-web-server-from-LAN-from-Internet-OK/m-p/1754823#M55009 - has detailed information that explains the router is re-routing requests back internally without doing a DNS lookup. This is why things fail.

  • It would not be Comcast. If you can install WireShark and capture all packets surrounding the request to failure/error, that would help. But this is a lot of data that requires some level of expertise to understand. If you feel comfortable with this activity, then the data will give a clue somewhere.
    – closetnoc
    Commented May 13, 2014 at 14:39
  • Thanks, may have to try that later this morning. Out of curiosity, I ran a trace route to the external hostname, and that seems to work from inside my network (it goes out and comes right back to the internal IP address). Odd that web traffic is blocked. Grrr.. will update if I find anything else interesting.
    – Charlie74
    Commented May 13, 2014 at 15:14
  • Well, you would think. But not always. For example, I found that DNS queries were failing and second and third requests were required at times. The firewall was fragmenting the DNS request causing it to fail more times than succeed for periods. As well, there were things to set in my internal DNS that was not necessary before the new firewall. I had to modify code to know better when a DNS request failed. I still have not figured out why the firewall was fragmenting my requests, but at least there was a work-around. It can be a something as simple and obscure as that.
    – closetnoc
    Commented May 13, 2014 at 15:24
  • This sounds like a problem specific to your setup; therefore it doesn't seem like this would be helpful to others in the future. Look for LAN firewall settings in your router, or use another one or network card to provide the DHCP/NAT with.
    – dan
    Commented May 14, 2014 at 3:04
  • 1
    Thanks @dan, I added as an answer. Hopefully others banging their head as I've been the last few days find it helpful.
    – Charlie74
    Commented May 14, 2014 at 22:07

3 Answers 3


After much research, I found this article on the Comcast forums: http://forums.comcast.com/t5/Home-Networking-Router-WiFi/SMCD3G-Can-t-access-web-server-from-LAN-from-Internet-OK/m-p/1754823#M55009

Essentially, certain models of Comcast routers (both home and business class) will experience an "issue" where requests made from inside the network "die" at the router. It has to do with NAT, and it appears that some routers will send the request up to the DNS server to resolve, and some will stop the request right there.

The "solution" is to just use the internal IP address of website... though I am disappointed by this, as it seems silly to me that the router can't resolve itself. But, it is what it is.

Hopefully this answer helps anyone else running in to the same issue as myself... trying to figure out why a site can be accessed externally and not internally.


Try use an internal router, forward all NAT from your ADSL router to the IP address of your internal router and configure Internal router to forward HTTP service to your hosting machine. It is definitely router issue..

Try use basic router like D-link for internal. example: external (ADSL) NAT Forward to all service ports Internal WAN Settings to DHCP, Forward NAT Port 80 or preferable to (WEBHOSTING Server)


  • The OP is using Comcast, a cable provider, and the rules are different especially using their own router which is always provided these days.
    – closetnoc
    Commented Aug 23, 2017 at 3:47

Only add A record to your DNS zone file with your server IP and you will be able to browse your web from local lan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.