2

I recently purchased an unmanaged VPS to host my business websites, however I am struggling to get the email accounts working as I have only ever had experience with shared hosting.

The VPS is running CentOS and I have Webmin/Virtualmin installed. I have added my domain, which is lyke.org.uk, and that is working OK. However, when I've added a user and tried to access their email account using Apple Mail, I've been able to establish a SMTP connection but I've not been able to login using POP.

Furthermore, I've set up squirrelmail and I can send an email to any email address from there but I haven't recieved any that I have sent to that email address from other accounts.

I would very much appreciate any help or suggestions as I am completely new to VPS and web hosting without Plesk or cPanel.

  • Is Dovecot IMAP/POP3 installed? BTW- some will argue, but I have had good luck with VirtualMin. – closetnoc Apr 17 '14 at 15:39
  • @closetnoc Yes, Dovecat, and Postfix is installed – Andy Apr 17 '14 at 15:40
  • Try this to test: anta.net/misc/telnet-troubleshooting/pop.shtml. I seem to remember that Dovecot was a bit fiddlie at first but has worked fine for years with issues- so it is worth it in the end. – closetnoc Apr 17 '14 at 15:56
  • @closetnoc Just tried that test and it is working fine. I can login to the server using Telnet with no issues. What could the problem be? – Andy Apr 17 '14 at 16:13
  • Interesting. If you can log in, then I would say the problem is on the client side. Check that your client(s) are using POP3 (you just tested POP3) an not IMAP which may be a default these days. Once done, you may want to check into IMAP for the future. I still use POP3, but I never go over the Internet for e-mail. – closetnoc Apr 17 '14 at 16:24
1

I should have posted this answer a while ago as thanks to @closetnoc I actually managed to get the mail server working correctly the same night I posted this question. As memory serves, the following was the solution to my issue.

I had changed the username format for the mail usernames under 'System Settings'->'Server Templates'->'Mail for domain' to be username@domain instead of username.domain which was the root of the login issue. The saslauthd daemon that is responsible for sending email securely must be running with the -r flag to accept usernames in this format. For CentOS, which is what my VPS is running, the method to make saslauthd run with the -r flag by default can be found on the following forum topic: https://www.virtualmin.com/node/15570

It took me more time to resolve this on my server as I had changed other settings in Webmin in trying to get it to work. The moral is that if you use Virtualmin, you should very rarely need to go into Webmin and alter settings (especially for mail) as this can often cause more issues and is unnecessary.

One other complication I had was that the domain was also being hosted on a shared hosting server and even though the domain was pointing to the name servers of the VPS, the shared hosting server still had the DNS records enabled for the domain. This caused a conflict when I tried to send emails from other domains that were also hosted on the shared hosting server and meant that the emails were not being delivered. I simply disabled the domain in Plesk on my shared hosting server to resolve this.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.