0

I just want to save my preferred domain as www.example.com in Webmaster Tools but it simply shows the following error message:

Part of the process of setting a preferred domain is to verify that you own http://example.com/. Please verify http://example.com/.

I can't save the setting, any idea why this is happening?

Note: I already verified the www version, I have no idea to verify the no-www version.

2

To set the preferred domain, you need to verify both the www version and the no-www version in Webmaster Tools.

| improve this answer | |
  • I verified the www version, now how do I verify the no-www version, I have no idea to do this – Bala Apr 17 '14 at 5:53
  • 1
    Just add the domain without the www in Google WMT as well as the www version. – zigojacko Apr 17 '14 at 7:43
  • I have a problem, I verified both www and non-www version, I set my .htaccess redirection on my site ( I use www.example.com) , yet when I want to set preferred domain(www) in my VERIFIED non-www version in search console, it says - Part of the process of setting a preferred domain is to verify that you own ..... . BUT not only is my www version is verified in console, it is also indexed well.Now, I see that the non-www version has no data whatsoever in console. The only problem is that I cant set the www preferred domain in site settings of non-www . – Tanvir Jun 28 '17 at 9:57
2

I run into the same problem, added both www and non-www, removed them, added again, verified both with multiple methods, but nothing. Finally I found out that I added https versions only and that is not enough for Google, and after I added both www and non-www with http (so actually FOUR versions of the same domain), finally Google let me set the preferred option.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.