1

I have hosted a site over shared hosting (ipage) and not have setup SSL certificate (which I don't need), but some how Google have indexed it as HTTPS link which popup security error on opening it. Check here.

I tried with 301 redirection by adding following in my .htaccess file:

<IfModule mod_rewrite.c>
     RewriteEngine On
     RewriteCond %{HTTPS} on
     RewriteRule .* http://%{HTTP_HOST}%{REQUEST_URI}
</IfModule>

But no luck with this. It may be because I am using shared hosting.

Only homepage is indexed as https other pages are indexed fine.

Is there any other way to tell Google to index it as HTTP instead of HTTPS?

1
  • I wouldn't recomment redirecting http to https as you will notice the page will be un-indexed by google for a couple of weeks and you may not get the ranking back to your original position, is there a setting you have mis-configured in webmaster tools, any extra links with https accidently? Apr 3, 2014 at 10:31

1 Answer 1

1

The best .htaccess code which I am able to give you to do the redirection is as following:

# This allows you to redirect your entire website
Redirect 301 / http://example.com/

You will have to modify the example as you add it into your .htaccess file.

1
  • 1
    2 other things: use absolute URLs within the site & use rel=canonical link elements. Apr 3, 2014 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.