I am developing a strategy game for web where there there will be a lot of client-server traffic for sending attacks, moves, etc. Right now I send messages from the client to the server via HTTP, and I want to try and setup SSL on my Ubuntu server which already has a LAMP stack installed and running.

Here are the guides I've followed:

After I installed the keys, I tried hitting my page using the https:// prefix, but I got an error:

SSL connection error. Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have. Error code: ERR_SSL_PROTOCOL_ERROR

After I received this error, I tried following: https://www.debian-administration.org/articles/349

This lead me around to modifying my 'ports.conf' file which now looks like:

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    NameVirtualHost *:443
    Listen 443

<IfModule mod_gnutls.c>
    NameVirtualHost *:443
    Listen 443

I restarted Apache successfully, and I can still hit my pages using HTTP, but not HTTPS (receiving the same error as before).

What step(s) am I missing?

  • do you have any certificate installed, even a trial one created by yourself?
    – PatomaS
    Commented Feb 24, 2014 at 6:29
  • have you read Ubuntu - HTTPD - Apache2 Web Server? or Apache2 SSL in Ubuntu? Or any other tutorial/manual/wiki explaining the process?
    – PatomaS
    Commented Feb 24, 2014 at 6:32
  • Reading your question and the Ubuntu documentation I don't see the step where the ssl module is enabled. Possibly dumb question, but have you run sudo a2enmod ssl yet? No harm in running the command a second time to check. Also, I've found the DigitalOcean documentation for setting up SSL to be easier to follow and more complete. Commented Feb 24, 2014 at 9:45
  • PatomaS: Yep, I created the certs and installed them, but I have not read your links yet. TomBrossman: I think I ran that command once before and it said it was already enabled, but I will check again. I am going to read each of the links provided and update my OP after I've tested them. Thanks for the responses! Commented Feb 24, 2014 at 15:17

1 Answer 1


The solution was located in digitalocean.com/community/articles/. I needed to perform the command: $ sudo a2ensite default-ssl

  • You saved me. After searching for hours this was the answer to my problem... Commented Nov 25, 2019 at 20:28
  • It works for me. Thank you so much! Commented Nov 7, 2022 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.