I have set up a subdomain which for some reason attaches #sthash.RXOAdGce.dpbs to the end of the URL making it look like this: <http://info.example.com/#sthash.gmiCS9nc.dpbs>.

I am wondering why this happens and how I can get rid of it.

As a bit of background info on things, the subdomain was set in cPanel on 1 server and an 'A' record set on a different server to redirect to the subdomain when the original site is eventually disabled.

  • when i open that url i dont get that hash, usually it would be generated by some clientside script on the target url, maybe your pc is hijacked – john Smith Feb 22 '14 at 12:49

According to this Google Group posting, it looks like adding Share This to your website will do this.

Have you added the ShareThis Gadget to your site? If so that is causing the issue. You'll need to contact ShareThis support to find out how to disable the URL changes

Well yes! Thank you! I just contacted with sharethis contact team!


Add shorten:false and it will not append the hash.

<script type="text/javascript">stLight.options({ doNotHash: false, doNotCopy: false, hashAddressBar: false , shorten:false});</script>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.