1

I would like to do 301 redirect from http://www.test.de/kollektion/b%C3%BCgel%20bh to http://www.test.de/bhs/bugel-bhs+balconette.

I tried to create a redirection rule, but it's not working even though I converted %C3%BCgel%20bh into ASCII code.

2
  • Can you add what you've tried to your question?
    – dan
    Jan 31, 2014 at 5:04
  • @dan as the first sentence but it's not redirected. Jan 31, 2014 at 7:55

1 Answer 1

1

To get this to work you will need to use the correct characters rather then the URL encoded characters.

Try adding the following in apache configuration file (apache2.conf/httpd.conf/apache.conf dependent on your distro)

AddDefaultCharset UTF-8

After restart apache using:

sudo service httpd restart

or

sudo service apache2 restart

Then in your htaccess file try the following:

Options +FollowSymLinks
Redirect 301 http://www.test.de/kollektion/bügel[\s]bh http://www.test.de/bhs/bugel-bhs+balconette
3
  • 1
    Nice one. Was hoping the OP would provide his .htaccess code so we could see the redirect link, but you decoded it for him.
    – dan
    Feb 1, 2014 at 1:55
  • @LiamSorsby bügel[\s]bh in the redirection rule that you provide turn into alien language when i put it into httpd.conf of my site. Feb 3, 2014 at 8:46
  • @DexterMoregan the bottom should be in your htaccess file not your httpd.conf file. Only the AddDefaultCharset UTF-8 should be added into your httpd.conf Feb 3, 2014 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.