I have a document like this:

    <meta charset="utf-8"/>
    <meta http-equiv="refresh" content="60" />
    <link rel="shortcut icon"  href="" 
        type="image/x-icon" />
    <span class="generated">18.12.2013 01:01:43</span>
    <p class="nobody">Nikogo nie wykryto.</p>

Here's my favicon, base64-encoded (I put the binary version on the server, of course):


Firefox doesn't seem to recognize this favicon - it's Windows 16x16 .ico format, PNG-compressed. It doesn't display it on a tab nor in bookmarks and in "page details" it says that its size is 0x0. What could be the reason?

  • Using Data URIs in the favicon is possible but remember browsers don't cache Data URIs... So what your doing is actually slowing the process down > stackoverflow.com/questions/5199902/… is a work around but to be honest even a JavaScript is a server side request which defealts the objective of even using a data URI to start off with. Best just to serve the favicon tbh. Dec 18, 2013 at 0:13
  • I didn't use Data URI in the original document, I used it here to display the file in a plaintext form.
    – d33tah
    Dec 18, 2013 at 0:31
  • Sorry, that's what happens when I skim questions :P Dec 18, 2013 at 11:42

2 Answers 2


I decoded that image and opened it with Firefox. Firefox was able to read it just fine.

I visited your website (found through reverse image search for the icon) and confirmed that in Firefox, the icon does not show up in the tab.

I looked at your source code. You should add the following code into the head of your website. It will trigger browsers other than Internet Explorer to fetch the favicon:

<link rel="shortcut icon" href="/favicon.ico"> 
  • 1
    What you probably looked at is /, while the document is located at /mac2/, here: - as you can see, the rel is already there.
    – d33tah
    Dec 18, 2013 at 0:26
  • 2
    The favicon shows up in the tab there for me. Dec 18, 2013 at 1:43
  • @StephenOstermiller: Just curious how you did a "reverse image search"? If I do, what I think is, a reverse image search in Google I get 5 other sites, not the site in question. (But the IP address would seem to already be given in the question...?)
    – MrWhite
    Dec 19, 2013 at 0:07
  • Yes, I think I got the wrong site when I dragged the image into Google image search. Dec 19, 2013 at 1:46
  • You can take a look at browser screenshots to see if your favicon appears or not, as with here (check for Firefox versions) - seems OK to me too.
    – dan
    Dec 19, 2013 at 18:35

I had this problem with Firefox too. On my website the favicon on http://example.com worked fine but not on http://www.example.com.

I fixed it by hardcoding the favicon.

<link rel='shortcut icon' type='image/x-icon' href='http://example.com/favicon.ico'>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.