I have a 32x32 favicon (in .ico format) that shows up fine in Firefox 3.6.12 and Chrome 5.0.375.70. But in Internet Explorer 7.0.5730.13 it looks terrible. It also looks bad in Windows Explorer (XP).

(Hmmm, I can't upload it - perhaps .ico format is blocked?)

(It's not IE8 but there is no other tag)

  • Re-tagged as IE7 for you.
    – Whitingx
    Nov 18 '10 at 15:15
  • This doesn't appear to be the best site for this question. I believe the webmasters.stackexchange.com would be a better fit.
    – user1100
    Nov 18 '10 at 15:16
  • 2
    Perhaps a link to your favicon would be helpful
    – John Conde
    Nov 18 '10 at 15:47
  • Or at the very least describe how it looks "terrible". Nov 18 '10 at 16:35
  • 1
    @Lèse majesté - good point, sorry. I think the pixelated comment in the answer below summarises it well. E.g. the image contains one letter, very clearly (in FF & GC). But in IE it is unreadable. Nov 18 '10 at 18:58

Check out this question on Stack Overflow, https://stackoverflow.com/questions/4031718/favicon-is-pixelated-in-ie.

It looks like 32x32 pixel favicons look much better in IE7 than 16x16. The only down side is Chrome only supports 16x16.

Here is an article going in depth into how favicons work and what your options are, http://perishablepress.com/press/2007/10/17/everything-you-ever-wanted-to-know-about-favicons/.

  • @RandomBen - that looks great, thank you. I will try it (32x32) out and get back to you. Nov 18 '10 at 18:59
  • @RandomBen - having said that, at the SO answer there does not seem to be a one size fits all - it looks like I need to choose between IE & Chrome. Perhaps I should not use .ico? Nov 18 '10 at 19:01
  • @RandomBen - clarified question - I checked again: the icon is in 32x32. OK in Chrome, NOK in IE7 - which is the opposite of your response. Weird. Nov 19 '10 at 7:45
  • @RandomBen - I've tried 16x16 and 32x32 versions of the icon, in .ico & .jpg format - all failed in IE. Nov 19 '10 at 10:55
  • @RandomBen - also, only .ico preserves transparency (the icon is round, not square). Nov 19 '10 at 11:07

It turns out that the solution, at least in my case, is to save in 32x32 .ico format but with the transparency turned off.

In addition - when I use this in MediaWiki it only goes wrong using the default name: favicon.ico. When I use a non default name, the problem goes away!

In Local Settings.php:

$wgFavicon = '<name>.ico';
  • You will have to look into it deeper but IE doesn't look at the favicon link it instead looks for a file in your root folder with the name favicon.ico so technically you can use different files for different browsers. Check out yourhtmlsource.com/promotion/favicon.html Nov 19 '10 at 15:28
  • @RandomBen - well, it definitely changed when I used non-default, which is weird. Thanks for the feedback. Good tip about different files for different browsers - thanks. Nov 19 '10 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.