1

I sometimes access my own website from my home/work/girlfriend IP addresses. I'd like to create a filter that includes any of these and nothing else. I thought a custom include filter with a very basic regex should do the trick. The regex I use is 62\.58\.32\.193|77\.172\.143\.12$|213\.125\.166\.98 to include

  • 62.58.32.193 and
  • 77.172.143.12 and
  • 213.125.166.98

and no other IP addresses. I obviously tested it before using it. However, pageviews seem to be stuck at zero even though I did generate internal traffic. Does anybody understand what I'm doing wrong? enter image description here

  • Are you applying any other filters to your profile (view)? – Blexy Nov 6 '13 at 1:41
  • Are you using AdBlock software that would prevent your hits from getting tracked by Google Analytics? – Stephen Ostermiller Nov 17 '13 at 19:40
  • No, it's already working. I just didn't wait long enough for the pageviews to become visible. Also the GA overview page came up with zero pageviews even though drilling down did show some pageviews. Thx guys anyway! – RubenGeert Nov 18 '13 at 20:23
1

This post seems to be getting a lot of views, despite being created in 2013. While you might have solved this since then, this answer if more for the people finding it through search.

First of, glad you are using a testing view, that way you don't mess with any Raw data. Always essential and easily forgotten.

  • If the issue is with the RegEx, try setting up an individual filter for each of the IP addresses.

  • If you need to test this or more advanced regEx, try the RegExR website.

If this did not solve the issue, I would look to make sure the tracking code is correctly installed on all the pages. Google Tag assistant can help with this.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.