For the last 2 days I've been trying to find the reason why the link to my website's Facebook page doesn't work anymore. The link went to facebook.com/company-page, but now redirects to facebook.com. I assume that I mistakenly changed something in the Facebook developer area, but I can't remember what it was.

I guess I saw some redirect in the tab, but I'm not sure since it's changing too fast to facebook.com.

The original link in the footer is correct:

<a href="http://facebook.com/company-page " target="_blank" class="facebook_ico"></a>

Any ideas?

1 Answer 1


Facebook sometimes redirects business pages to the homepage if your country settings or age restriction settings are not set to show the page to everyone. Have you changed yours?

  1. Log in to Facebook.

  2. Click the Settings cog in the top-right, and choose "Use Facebook as [Your Business]"

  3. Choose Edit Page > Edit Settings from the dropdown in the top-middle of the page.

  4. Check that "Country Restrictions" and "Age Restrictions" both say "Page is visible|shown to everyone":

    Facebook page settings

  • THanks a lot for your answer, when I checked it again, I noticed a notification at the top of the page (over the background image) which said, that the page isn't published yet (underline). I still don't know how I disabled it, but I clicked on it and the page is now working again.
    – Teo
    Oct 23, 2013 at 18:24
  • @Teo Great to hear you got it working. Thanks for mentioning your solution – it might help others in the future.
    – Nick
    Oct 23, 2013 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.